股票配资期货综合门户论坛

 找回密码
 立即注册
查看: 252|回复: 0

通达信公式戌狗火山爆发源码附图

[复制链接]

0

主题

0

帖子

0

积分

版主

Rank: 7Rank: 7Rank: 7

积分
0
发表于 2019-6-12 01:53:16 | 显示全部楼层 |阅读模式
  N:=30;M:=13;
  LC := REF(CLOSE,1);
  RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
  RSIF:=90-RSI1,COLOR33DD33;
  A4:=((C-LLV(L,33))/(HHV(H,33)-LLV(L,33)))*67;
  VAR22:=LLV(LOW,10);
  VAR33:=HHV(HIGH,25);
  动力线:EMA((CLOSE-VAR22)/(VAR33-VAR22)*4,4);
  RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
  PP101:=SMA(RSV,3,1);
  PP102:=SMA(PP101,3,1);
  PP103:=3*PP101-2*PP102;
  STICKLINE(动力线>0 AND ISLASTBAR AND ((PP103>P101 AND PP103PP101),20,80,0,1),COLORGRAY;
  STICKLINE(动力线>=0.2 AND 动力线PP101 AND PP103PP101),20,35,2,1),COLORGRAY;{底部保持关注,灰色}
  STICKLINE(动力线>=0.5 AND 动力线PP101 AND PP103PP101),35,50,2,0),COLORYELLOW;{底部酌情买入,黄色}
  STICKLINE(动力线>=1.75 AND 动力线PP101 AND PP103PP101),50,65,2,0),COLORRED;{强势持仓段,红色}
  STICKLINE(动力线>=3.2 AND 动力线PP101 AND PP103PP101),65,72,2,0),COLORLIRED;{阶段卖出,粉红}
  STICKLINE(动力线>=3.45 AND ISLASTBAR,72,80,2,0) AND PP103PP101 AND PP103PP101),95,94,1,0),COLORGRAY;
  STICKLINE(动力线>=0.2 AND 动力线PP101 AND PP103PP101),95,92,3,0),COLORGRAY;{底部保持关注,灰色}
  STICKLINE(动力线>=0.5 AND 动力线PP101 AND PP103PP101),95,94,1,0),COLORYELLOW;{底部酌情买入,黄色}
  STICKLINE(动力线>=1.75 AND 动力线PP101 AND PP103PP101),95,94,1,0),COLORRED;{强势持仓段,红色}
  STICKLINE(动力线>=3.2 AND 动力线PP101 AND PP103PP101),95,92,3,0),COLORLIRED;{阶段卖出,粉红}
  STICKLINE(动力线>=3.45,95,92,3,0) AND PP103 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
  强弱分界:=50,COLORFFFFCC;
  底部:=0,COLOR00FFFF;
  安全:=20,COLORFFAA66,LINETHICK1;
  预警:=80,COLORFFAA66,LINETHICK1;
  顶部:=100,COLORFFFF33;
  V1:=LLV(LOW,10);
  V2:=HHV(H,25);
  价位线:=EMA((C-V1)/(V2-V1)*4,4);
  DRAWTEXT(CROSS(3.5,价位线),110-4,"●卖"),COLORWHITE;
  VAR2Q:=REF(LOW,1);
  VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
  VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
  VAR5Q:=LLV(LOW,30);
  VAR6Q:=HHV(VAR4Q,30);
  VAR7Q:=IF(MA(CLOSE,58),1,0);
  VAR8Q:=EMA(IF(LOW100,100,VAR8Q);
  AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
  AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
  AA5:=SMA(AA4,13,8);
  走势:=CEILING(SMA(AA5,13,8));
  AA6:=SMA(AA3,21,8);
  卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
  VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
  VAR21:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
  VAR31:=EMA(VAR21,10);
  VAR41:=LLV(LOW,33);
  VAR51:=EMA(IF(LOWREF(VAR51,1),VAR51,0),COLORRED,NODRAW;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLOR000055;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.6,0 ),COLOR000077;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0 ),COLOR000099;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.5,0 ),COLOR0000BB;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.9,0 ),COLOR0000DD;
  STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0 ),COLOR0000FF;
  洗盘:IF(VAR51
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|股票配资财经论坛 ( 吉ICP备09002727号-1

GMT+8, 2019-8-24 07:53 , Processed in 0.113663 second(s), 23 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表