请选择 进入手机版 | 继续访问电脑版

股票配资期货综合门户论坛

 找回密码
 立即注册
查看: 327|回复: 0

通达信金牌逃顶源码附图不含未来函数

[复制链接]

0

主题

0

帖子

2

积分

超级版主

Rank: 8Rank: 8

积分
2
发表于 4 天前 | 显示全部楼层 |阅读模式
  VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
  VAR2:=SMA(VAR1,9,1)+100;
  VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  VAR4:=SMA(VAR3,3,1);
  VAR5:=SMA(VAR4,3,1)+100;
  VAR6:=VAR5-VAR2;
  趋势: IF(VAR6>45,VAR6-45,0);
  STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2,0),COLORMAGENTA;
  STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
  强弱分界:50,COLORFFFFCC;
  底部:0,COLOR00FFFF;
  安全:20,COLORFFAA66,LINETHICK1;
  预警:80,COLORFFAA66,LINETHICK1;
  顶部:100,COLORFFFF33;
  V1:=LLV(LOW,10);
  V2:=HHV(H,25);
  价位线:=EMA((C-V1)/(V2-V1)*4,4);
  DRAWTEXT(CROSS(价位线,0.3),20+4,'●买'),COLORRED;
  DRAWTEXT(CROSS(3.5,价位线),100-4,'●卖'),COLORGREEN;
  VAR2Q:=REF(LOW,1);
  VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
  VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
  VAR5Q:=LLV(LOW,30);
  VAR6Q:=HHV(VAR4Q,30);
  VAR7Q:=IF(MA(CLOSE,58),1,0);
  VAR8Q:=EMA(IF(LOW100,100,VAR8Q);
  吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,3,1),COLORYELLOW;
  AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
  AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
  AA5:=SMA(AA4,13,8);
  走势:=CEILING(SMA(AA5,13,8));
  AA6:=SMA(AA3,21,8);
  卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
  主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
  SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1,POINTDOT;
  超短线((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORLIRED;
  VAR11:=3;
  VAR21:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
  股价准备启动:IF(CROSS(VAR21,VAR11),100,0),COLORRED,LINETHICK2;



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|股票配资财经论坛 ( 吉ICP备09002727号-1

GMT+8, 2019-6-16 21:12 , Processed in 0.116835 second(s), 23 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表